Scroll To Top

Important : Support Portal Security Upgrade

<p>To ensure the security of our systems, and maintain our compliance with the PCI Data Security Standard (PCI DSS), the <strong><a href="https://support.cytrack.com" target="_blank" rel="noopener">CyDesk Support Portal</a></strong> is updating to require a minimum of version 1.2 of TLS for all HTTPS connections.  Support for TLS versions 1.0 and 1.1 is therefore being deprecated and as a result from <strong>June 14, 2018</strong> customers using older browsers will be unable to securely access the CyTrack Support Portal.</p>
<p> </p>
<h2 class="null">What do I need to do?</h2>
<p>To continue using the CyDesk Support Portal after June 14, 2018, you will need to <strong>ensure you are using a modern browser</strong> with support for TLS 1.2 or higher, such as the latest version of Chrome, Edge, Firefox or Safari (see the list below).<br />  </p>
<h2 class="null">Which browsers can I use?</h2>
<ul>
<li>Chrome: 49, 63, 64, 65, 66, 67, 68</li>
<li>Edge: 16, 17, 18</li>
<li>Internet Explorer: 11</li>
<li>Firefox: 58, 59, 60, 61</li>
<li>Safari: 11</li>
<li>IOS Safari: 10.3, 11.2, 11.3</li>
<li>Chrome for Android: 64</li>
<li>UC Browser for Android: 11.8</li>
<li>Samsung Internet: 4, 6.2<br />  </li>
</ul>
<h2>What happens if I don’t upgrade my browser?</h2>
<p>If you are running an unsupported, older web browser, you will be unable to securely access the CyTrack Support Portal beginning June 14, 2018.<br />  </p>

Have more questions? Submit a request

Comments