Scroll To Top

Support Portal Security Update

To ensure the security of our systems, and maintain our compliance with the PCI Data Security Standard (PCI DSS), the CyDesk Support Portal is updating to require a minimum of version 1.2 of TLS for all HTTPS connections.  Support for TLS versions 1.0 and 1.1 is therefore being deprecated and as a result from June 14, 2018 customers using older browsers will be unable to securely access the CyTrack Support Portal.

 

What do I need to do?

To continue using the CyDesk Support Portal after June 14, 2018, you will need to ensure you are using a modern browser with support for TLS 1.2 or higher, such as the latest version of Chrome, Edge, Firefox or Safari (see the list below).
 

Which browsers can I use?

  • Chrome: 49, 63, 64, 65, 66, 67, 68
  • Edge: 16, 17, 18
  • Internet Explorer: 11
  • Firefox: 58, 59, 60, 61
  • Safari: 11
  • IOS Safari: 10.3, 11.2, 11.3
  • Chrome for Android: 64
  • UC Browser for Android: 11.8
  • Samsung Internet: 4, 6.2
     

What happens if I don’t upgrade my browser?

If you are running an unsupported, older web browser, you will be unable to securely access the CyTrack Support Portal beginning June 14, 2018.
 

Have more questions? Submit a request

Comments